Receba conteúdos exclusivos no seu e-mail

Receba conteúdos sobre Excel, VBA, Análise de Dados e Dashboard.

Por mais que o título do artigo pareça uma chamada de app de relacionamento, não é. Você vai aprender a usar as Funções Índice e Corresp para fazer pesquisas no Excel.

Quando falamos em Índice e Corresp, estamos combinando duas funções. E esta combinação gera uma fórmula que torna possível buscar informações em qualquer direção da planilha.

Neste artigo, você vai aprender a:

  • Usar a Função Corresp;
  • Usar a Função Índice;
  • Combinar Índice e Corresp para gerar uma poderosa fórmula de pesquisa.

curso excel pesquisa de dados

Estudo de caso: encontrando o seu amor

Para explicar as Funções Índice e Corresp, usarei uma planilha onde você digita seu signo, um local e a fórmula retorna o percentual de chances de você encontrar seu amor. Veja:

índice e corresp

Os valores são aleatórios Ok? O exemplo é só uma forma diferente de apresentar o conteúdo, com o objetivo de fazer você entender os conceitos das funções Índice e Corresp.

O resultado da pesquisa é de 72%, usando como signo câncer e local trilha. Como o Excel chegou a este resultado?

A área branca é a matriz de dados. É como se eu dissesse assim: Excel, traz a informação que está na linha 4 e coluna 5 da matriz.

índice e corresp

Para acompanhar o artigo, faça o download da planilha aqui.

Então nós temos a matriz em C4:H15, linha 4, coluna 5. É importante identificar que linha e coluna são contados a partir do intervalo de matriz, e não dos endereços do Excel.

Por exemplo, a célula onde está o signo câncer, é a linha 7 do Excel. Mas na matriz, que inicia na linha 4, ela é a quarta linha.

Entenda como cada função funciona individualmente.

Conteúdos exclusivos no seu e-mail

Receba conteúdos sobre Excel, VBA, Análise de Dados e Dashboard.

privacy Fique tranquilo, não enviamos spam.

Função Índice

A Função Índice retorna a informação na interseção de linha e coluna.

Sabe o jogo batalha naval? Então, Índice funciona assim. Você aponta as coordenadas e a função retorna a informação que está lá. No caso do jogo, você acerta o navio adversário.

A sintaxe da Função Índice é: =ÍNDICE (Matriz;Núm_linha;Núm_coluna)

Usando apenas a Função Índice, a fórmula para retornar o percentual de chances ficaria assim: =ÍNDICE(C4:H15;4;5).

Ou seja, dentro da matriz, eu quero a informação da linha 4 e coluna 5.

índice e corresp

Veja que neste caso, tive que contar para saber a posição das informações: câncer na linha 4 e trilha na coluna 5. Existem 2 problemas aí.

  • Identificar manualmente a posição das informações.
  • A fórmula não atualiza se trocarmos o signo e/ou o local.

É justamente aqui que a Função Corresp entra, pois ela traz a posição da informação. Logo, não precisarei contar manualmente.

Função Corresp

A Função Corresp retorna a posição da informação dentro de uma matriz. Sua sintaxe é: =CORRESP(Valor_procurado;Matriz_procurada;Tipo_correspondência)

Em nosso exemplo, vamos usar a Função Corresp duas vezes.

Para retornar a posição do signo: CORRESP(J3;B4:B15;0) – O resultado é 4.

Para retornar a posição do local: CORRESP(K3;C3:H3;0) – O resultado é 5.

índice e corresp

Observação: o zero na Função Corresp significa um tipo de correspondência exata. O valor procurado tem que ser exato, não aproximado. Este é o mesmo conceito usado na Função PROCV.

Juntando as funções, temos a seguinte fórmula:

=ÍNDICE(C4:H15;CORRESP(J3;B4:B15;0);CORRESP(K3;C3:H3;0))

Usando Índice e Corresp Passo a Passo

Você pode usar a fórmula completa como mostrei acima na célula L3 para retornar o resultado. Eu prefiro usar o assistente de função. Veja o passo a passo a seguir:

1) Clique na célula L3.

2) Clique na guia Fórmulas → grupo Biblioteca de Funções → Pesquisa e Referência → ÍNDICE.

índice e corresp

3) Será exibida a caixa Selecionar argumentos. Deixe marcada a primeira opção e clique em OK.

índice e corresp

4) Em Matriz, selecione o intervalo C4:H15 (intervalo dos percentuais). Em Núm_linha, clique na seta ao lado da barra de fórmulas e insira a Função CORRESP.

índice e corresp

5) Em Valor_procurado, clique na célula J3 (signo a ser procurado). Em Matriz, selecione o intervalo B4:B15 (lista de signos). Em Tipo_correspondência, digite zero.

índice e corresp

6) Não clique em OK. Na barra de fórmulas, clique sobre a Função Índice.

índice e corresp

7) Clique no argumento Núm_coluna. Novamente clique na seta ao lado da barra de fórmulas e insira a Função CORRESP.

8) Em Valor_procurado, clique na célula K3 (local). Em Matriz_procurada, selecione o intervalo C3:H3 (lista de locais). Em Tipo_correspondência, digite zero.

índice e corresp

9) Agora sim, clique em OK. O resultado retornado é 72%.

Digite seu signo, escolha um local e veja quais as chances de encontrar seu amor 😊

Videoaula

Clique aqui e assista uma videoaula com outro exemplo de combinação destas funções.

Participe

O que achou das Funções Índice e Corresp do Excel? Deixe sua opinião nos comentários.

Se este conteúdo foi relevante para você, convide seus amigos para que eles também fiquem sabendo deste material.

Um abraço e até a próxima.
curso excel pesquisa de dados